$re = '/(?:^|\D)(1\d{7})(?:\D|$)/m';
$str = 'a12891212a
a 12891212 a
128912120a
23456789
11233456789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);