import re
regex = re.compile(r"(?:^|\D)(1\d{7})(?:\D|$)", flags=re.MULTILINE)
test_str = ("a12891212a\n"
"a 12891212 a\n"
"128912120a\n"
"23456789\n"
"11233456789")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")