#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^enum[^{]*{\s*(?!\b[A-Z]+\b)(\w+(?:\s*,\s*(?!\b[A-Z]+\b)\w+)*)\s*}"
Local $sString = "enum TransparencyState {" & @CRLF & _
" Gone, Translucent, Opaque" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"enum TransparencyState {" & @CRLF & _
" GONE, TRANSLUCENT, OPAQUE_OR_DULL" & @CRLF & _
" }" & @CRLF & _
"" & @CRLF & _
"enum TransparencyState {" & @CRLF & _
" gone, " & @CRLF & _
" translucent, " & @CRLF & _
" opaque" & @CRLF & _
" }" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")