$re = '/^enum[^{]*{\s*(?!\b[A-Z]+\b)(\w+(?:\s*,\s*(?!\b[A-Z]+\b)\w+)*)\s*}/m';
$str = 'enum TransparencyState {
Gone, Translucent, Opaque
}
enum TransparencyState {
GONE, TRANSLUCENT, OPAQUE_OR_DULL
}
enum TransparencyState {
gone,
translucent,
opaque
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);