import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^enum[^\\{]*\\{\\s*(?!\\b[A-Z]+\\b)(\\w+(?:\\s*,\\s*(?!\\b[A-Z]+\\b)\\w+)*)\\s*\\}";
final String string = "enum TransparencyState {\n"
+ " Gone, Translucent, Opaque\n"
+ " }\n\n"
+ "enum TransparencyState {\n"
+ " GONE, TRANSLUCENT, OPAQUE_OR_DULL\n"
+ " }\n\n"
+ "enum TransparencyState {\n"
+ " gone, \n"
+ " translucent, \n"
+ " opaque\n"
+ " }\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}