re = /^enum[^{]*{\s*(?!\b[A-Z]+\b)(\w+(?:\s*,\s*(?!\b[A-Z]+\b)\w+)*)\s*}/m
str = 'enum TransparencyState {
Gone, Translucent, Opaque
}
enum TransparencyState {
GONE, TRANSLUCENT, OPAQUE_OR_DULL
}
enum TransparencyState {
gone,
translucent,
opaque
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end