const regex = /^enum[^{]*{\s*(?!\b[A-Z]+\b)(\w+(?:\s*,\s*(?!\b[A-Z]+\b)\w+)*)\s*}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^enum[^{]*{\\s*(?!\\b[A-Z]+\\b)(\\w+(?:\\s*,\\s*(?!\\b[A-Z]+\\b)\\w+)*)\\s*}', 'gm')
const str = `enum TransparencyState {
Gone, Translucent, Opaque
}
enum TransparencyState {
GONE, TRANSLUCENT, OPAQUE_OR_DULL
}
enum TransparencyState {
gone,
translucent,
opaque
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}