import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*?\\p{Han}.*\\n";
final String string = "A.我不要这些汉字\n"
+ "Ok I see\n"
+ "有人会懂我写的吗?\n"
+ "Why not then?\n"
+ "我看够呛。\n"
+ "This is just an example";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}