const regex = /^.*?\p{Han}.*\n/gmu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*?\\p{Han}.*\\n', 'gmu')
const str = `A.我不要这些汉字
Ok I see
有人会懂我写的吗?
Why not then?
我看够呛。
This is just an example`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);