re = /^.*?\p{Han}.*\n/m
str = 'A.我不要这些汉字
Ok I see
有人会懂我写的吗?
Why not then?
我看够呛。
This is just an example'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result