$re = '/^.*?\p{Han}.*\n/mu';
$str = 'A.我不要这些汉字
Ok I see
有人会懂我写的吗?
Why not then?
我看够呛。
This is just an example';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;