import re
regex = re.compile(r"^.*?\p{Han}.*\n", flags=re.MULTILINE | re.UNICODE)
test_str = ("A.我不要这些汉字\n"
"Ok I see\n"
"有人会懂我写的吗?\n"
"Why not then?\n"
"我看够呛。\n"
"This is just an example")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)