#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Release (\d+\.\d+[\.\d]?)"
Local $sString = "Release 2.6 Now Live" & @CRLF & _
"Release 12.46.30 Now Live" & @CRLF & _
"Release 2.6.0 Now Live" & @CRLF & _
"Release 2.6.1 Now Live"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")