import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Release (\\d+\\.\\d+[\\.\\d]?)";
final String string = "Release 2.6 Now Live\n"
+ "Release 12.46.30 Now Live\n"
+ "Release 2.6.0 Now Live\n"
+ "Release 2.6.1 Now Live";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}