use strict;
my $str = 'Release 2.6 Now Live
Release 12.46.30 Now Live
Release 2.6.0 Now Live
Release 2.6.1 Now Live';
my $regex = qr/Release (\d+\.\d+[\.\d]?)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}