import re
regex = re.compile(r"Release (\d+\.\d+[\.\d]?)")
test_str = ("Release 2.6 Now Live\n"
"Release 12.46.30 Now Live\n"
"Release 2.6.0 Now Live\n"
"Release 2.6.1 Now Live")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")