#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(-|\d)+(\.\d{1,2})?"
Local $sString = "-100.00" & @CRLF & _
"1,000.00" & @CRLF & _
"100,000.00" & @CRLF & _
"1,000,000.00" & @CRLF & _
"00.7" & @CRLF & _
"0.00" & @CRLF & _
"" & @CRLF & _
"-0909099993.2899999999999974" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"-3.2899999999999974" & @CRLF & _
"^(?!0\.00)[1-9]\d{0,2}(,\d{3})*(\.\d\d)?$" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"BOM" & @CRLF & _
"(-|\d)+(?=(\d{3})+(\d{3})+(\.\d{1,2}))" & @CRLF & _
"BOM" & @CRLF & _
"^(-|\d)(\d{1,3})(\.\d{1,2})?" & @CRLF & _
"(\w[-._+\w]*\w@\w[-._\w]*\w\.\w{2,3})" & @CRLF & _
"" & @CRLF & _
"^(?!0\.00)\d{1,3}(,\d{3})*(\.\d\d)?$" & @CRLF & _
".replace(/(\d)(?=(\d{3})+(?!\d))/g, "$1,") # => "10,000""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")