import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(-|\\d)+(\\.\\d{1,2})?";
final String string = "-100.00\n"
+ "1,000.00\n"
+ "100,000.00\n"
+ "1,000,000.00\n"
+ "00.7\n"
+ "0.00\n\n"
+ "-0909099993.2899999999999974\n\n\n"
+ "-3.2899999999999974\n"
+ "^(?!0\\.00)[1-9]\\d{0,2}(,\\d{3})*(\\.\\d\\d)?$\n\n\n"
+ "BOM\n"
+ "(-|\\d)+(?=(\\d{3})+(\\d{3})+(\\.\\d{1,2}))\n"
+ "BOM\n"
+ "^(-|\\d)(\\d{1,3})(\\.\\d{1,2})?\n"
+ "(\\w[-._+\\w]*\\w@\\w[-._\\w]*\\w\\.\\w{2,3})\n\n"
+ "^(?!0\\.00)\\d{1,3}(,\\d{3})*(\\.\\d\\d)?$\n"
+ ".replace(/(\\d)(?=(\\d{3})+(?!\\d))/g, \"$1,\") # => \"10,000\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}