# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(-|\d)+(\.\d{1,2})?"
test_str = ("-100.00\n"
"1,000.00\n"
"100,000.00\n"
"1,000,000.00\n"
"00.7\n"
"0.00\n\n"
"-0909099993.2899999999999974\n\n\n"
"-3.2899999999999974\n"
"^(?!0\\.00)[1-9]\\d{0,2}(,\\d{3})*(\\.\\d\\d)?$\n\n\n"
"BOM\n"
"(-|\\d)+(?=(\\d{3})+(\\d{3})+(\\.\\d{1,2}))\n"
"BOM\n"
"^(-|\\d)(\\d{1,3})(\\.\\d{1,2})?\n"
"(\\w[-._+\\w]*\\w@\\w[-._\\w]*\\w\\.\\w{2,3})\n\n"
"^(?!0\\.00)\\d{1,3}(,\\d{3})*(\\.\\d\\d)?$\n"
".replace(/(\\d)(?=(\\d{3})+(?!\\d))/g, \"$1,\") # => \"10,000\"")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.