re = /(-|\d)+(\.\d{1,2})?/
str = '-100.00
1,000.00
100,000.00
1,000,000.00
00.7
0.00
-0909099993.2899999999999974
-3.2899999999999974
^(?!0\\.00)[1-9]\\d{0,2}(,\\d{3})*(\\.\\d\\d)?$
BOM
(-|\\d)+(?=(\\d{3})+(\\d{3})+(\\.\\d{1,2}))
BOM
^(-|\\d)(\\d{1,3})(\\.\\d{1,2})?
(\\w[-._+\\w]*\\w@\\w[-._\\w]*\\w\\.\\w{2,3})
^(?!0\\.00)\\d{1,3}(,\\d{3})*(\\.\\d\\d)?$
.replace(/(\\d)(?=(\\d{3})+(?!\\d))/g, "$1,") # => "10,000"'
# Print the match result
str.match(re) do |match|
puts match.to_s
end