use strict;
my $str = '-100.00
1,000.00
100,000.00
1,000,000.00
00.7
0.00
-0909099993.2899999999999974
-3.2899999999999974
^(?!0\\.00)[1-9]\\d{0,2}(,\\d{3})*(\\.\\d\\d)?$
BOM
(-|\\d)+(?=(\\d{3})+(\\d{3})+(\\.\\d{1,2}))
BOM
^(-|\\d)(\\d{1,3})(\\.\\d{1,2})?
(\\w[-._+\\w]*\\w@\\w[-._\\w]*\\w\\.\\w{2,3})
^(?!0\\.00)\\d{1,3}(,\\d{3})*(\\.\\d\\d)?$
.replace(/(\\d)(?=(\\d{3})+(?!\\d))/g, "$1,") # => "10,000"';
my $regex = qr/(-|\d)+(\.\d{1,2})?/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}