using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[(?<key>\S+)\s+""(?<value>[^""]+)";
string input = @" 2020/03/01-10:01:01 [firstname ""JOHN""] [surename ""DOE""] [age ""30""] [state ""NY""] [id ""10001""]
2020/03/01-10:01:02 [firstname ""Julie""] [age ""58""] [state ""AU""] [id ""10002""]
2020/03/01-10:01:02 [firstname ""MEGAN""][middlename ""myra""] [surename ""DOE""] [age ""58""] [state ""AU""] [id ""10052""]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}