# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\[(?<key>\S+)\s+\"(?<value>[^\"]+)"
test_str = (" 2020/03/01-10:01:01 [firstname \"JOHN\"] [surename \"DOE\"] [age \"30\"] [state \"NY\"] [id \"10001\"]\n"
" 2020/03/01-10:01:02 [firstname \"Julie\"] [age \"58\"] [state \"AU\"] [id \"10002\"]\n"
" 2020/03/01-10:01:02 [firstname \"MEGAN\"][middlename \"myra\"] [surename \"DOE\"] [age \"58\"] [state \"AU\"] [id \"10052\"]")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.