import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[(?<key>\\S+)\\s+\"(?<value>[^\"]+)";
final String string = " 2020/03/01-10:01:01 [firstname \"JOHN\"] [surename \"DOE\"] [age \"30\"] [state \"NY\"] [id \"10001\"]\n"
+ " 2020/03/01-10:01:02 [firstname \"Julie\"] [age \"58\"] [state \"AU\"] [id \"10002\"]\n"
+ " 2020/03/01-10:01:02 [firstname \"MEGAN\"][middlename \"myra\"] [surename \"DOE\"] [age \"58\"] [state \"AU\"] [id \"10052\"]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}