// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\[(?<key>\S+)\s+"(?<value>[^"]+)"#).unwrap();
let string = " 2020/03/01-10:01:01 [firstname \"JOHN\"] [surename \"DOE\"] [age \"30\"] [state \"NY\"] [id \"10001\"]
2020/03/01-10:01:02 [firstname \"Julie\"] [age \"58\"] [state \"AU\"] [id \"10002\"]
2020/03/01-10:01:02 [firstname \"MEGAN\"][middlename \"myra\"] [surename \"DOE\"] [age \"58\"] [state \"AU\"] [id \"10052\"]";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}