#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)MIT-[\d\.\/\-]*"
Local $sString = " 2312312321312312 asadas-dasdasdads.ru MIT-1.3.2/14-29" & @CRLF & _
" 23123123 asadewrewras-deewrewrasdasdads.ru MIT-1.4.1/13-29" & @CRLF & _
" 2312312321312312 asadas-dasdasdads.ru MIT-1.3.2/2-29" & @CRLF & _
" 232222 aFEWFWewsadas-dasdasdads.ru MIT-1.3.4/12-30" & @CRLF & _
" 99999 aFEWFWewrrwerweadas-dasdasdads.ru MIT-1.4.1/4-6 #1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")