using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"MIT-[\d\.\/\-]*";
string input = @" 2312312321312312 asadas-dasdasdads.ru MIT-1.3.2/14-29
23123123 asadewrewras-deewrewrasdasdads.ru MIT-1.4.1/13-29
2312312321312312 asadas-dasdasdads.ru MIT-1.3.2/2-29
232222 aFEWFWewsadas-dasdasdads.ru MIT-1.3.4/12-30
99999 aFEWFWewrrwerweadas-dasdasdads.ru MIT-1.4.1/4-6 #1";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}