import re
regex = re.compile(r"MIT-[\d\.\/\-]*", flags=re.MULTILINE)
test_str = (" 2312312321312312 asadas-dasdasdads.ru MIT-1.3.2/14-29\n"
" 23123123 asadewrewras-deewrewrasdasdads.ru MIT-1.4.1/13-29\n"
" 2312312321312312 asadas-dasdasdads.ru MIT-1.3.2/2-29\n"
" 232222 aFEWFWewsadas-dasdasdads.ru MIT-1.3.4/12-30\n"
" 99999 aFEWFWewrrwerweadas-dasdasdads.ru MIT-1.4.1/4-6 #1")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")