use strict;
my $str = 'line 1
line2
luine3
line4';
my $regex = qr/[\r\n]+/mp;
my $subst = '\\r\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";