import re
regex = re.compile(r"[\r\n]+", flags=re.MULTILINE)
test_str = ("line 1\n"
"line2\n\n"
"luine3\n\n\n\n\n\n"
"line4")
subst = "\\r\\n"
result = regex.sub(subst, test_str)
if result:
print(result)