$re = '/[\r\n]+/m';
$str = 'line 1
line2
luine3
line4';
$subst = "\r\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;