const regex = /^.*\b(jack\b.*\bjames|james\b.*\bjack)\b.*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*\\b(jack\\b.*\\bjames|james\\b.*\\bjack)\\b.*$', 'gm')
const str = `hi jack here is james whats up
'hi james here is jack whats up`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}