// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^.*\b(jack\b.*\bjames|james\b.*\bjack)\b.*$").unwrap();
let string = "hi jack here is james whats up
'hi james here is jack whats up";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}