re = /^.*\b(jack\b.*\bjames|james\b.*\bjack)\b.*$/m
str = 'hi jack here is james whats up
\'hi james here is jack whats up'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end