$re = '/^.*\b(jack\b.*\bjames|james\b.*\bjack)\b.*$/m';
$str = 'hi jack here is james whats up
\'hi james here is jack whats up';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);