using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\.tpl).+\.html$";
string input = @"foo.html
bar.tpl.html
bar.html
bar.blah.blah
bar.tpl.tpl
bar.html.tpl.html
bar.html";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}