import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\.tpl).+\\.html$";
final String string = "foo.html\n"
+ "bar.tpl.html\n"
+ "bar.html\n"
+ "bar.blah.blah\n"
+ "bar.tpl.tpl\n"
+ "bar.html.tpl.html\n"
+ "bar.html";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}