const regex = /^(?!.*\.tpl).+\.html$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\.tpl).+\\.html$', 'gm')
const str = `foo.html
bar.tpl.html
bar.html
bar.blah.blah
bar.tpl.tpl
bar.html.tpl.html
bar.html`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}