re = /^(?!.*\.tpl).+\.html$/m
str = 'foo.html
bar.tpl.html
bar.html
bar.blah.blah
bar.tpl.tpl
bar.html.tpl.html
bar.html'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end