$re = '/^(?!.*\.tpl).+\.html$/m';
$str = 'foo.html
bar.tpl.html
bar.html
bar.blah.blah
bar.tpl.tpl
bar.html.tpl.html
bar.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);