import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^(?:(?:§.*|[^[:alpha:]\\n\\r]*[[:upper:]]+(?:[^[:alpha:]\\n\\r]+[[:upper:]]+)*[^[:alpha:]\\n\\r]*))$|(?i:\\bmany of\\b))|(?i:\\bof\\b)";
final String string = "§History of TIME\n"
+ "HISTORY OF TIME\n"
+ "of\n"
+ "Future\n"
+ "Past\n"
+ "Of\n"
+ "Many Of\n"
+ "Official\n"
+ "Officer";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}