const regex = /(^(?:(?:§.*|[^[:alpha:]\n\r]*[[:upper:]]+(?:[^[:alpha:]\n\r]+[[:upper:]]+)*[^[:alpha:]\n\r]*))$|(?i:\bmany of\b))|(?i:\bof\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^(?:(?:§.*|[^[:alpha:]\\n\\r]*[[:upper:]]+(?:[^[:alpha:]\\n\\r]+[[:upper:]]+)*[^[:alpha:]\\n\\r]*))$|(?i:\\bmany of\\b))|(?i:\\bof\\b)', 'gm')
const str = `§History of TIME
HISTORY OF TIME
of
Future
Past
Of
Many Of
Official
Officer`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);