import re
regex = re.compile(r"(^(?:(?:§.*|[^[:alpha:]\n\r]*[[:upper:]]+(?:[^[:alpha:]\n\r]+[[:upper:]]+)*[^[:alpha:]\n\r]*))$|(?i:\bmany of\b))|(?i:\bof\b)", flags=re.MULTILINE)
test_str = ("§History of TIME\n"
"HISTORY OF TIME\n"
"of\n"
"Future\n"
"Past\n"
"Of\n"
"Many Of\n"
"Official\n"
"Officer")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)