re = /(^(?:(?:§.*|[^[:alpha:]\n\r]*[[:upper:]]+(?:[^[:alpha:]\n\r]+[[:upper:]]+)*[^[:alpha:]\n\r]*))$|(?i:\bmany of\b))|(?i:\bof\b)/m
str = '§History of TIME
HISTORY OF TIME
of
Future
Past
Of
Many Of
Official
Officer'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result