using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\D+";
string input = @"1 ding ?
123 ding ?
123 ding ? 321
123 ding ? 457123 ding ? 457
1234567890";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}