re = /\D+/m
str = '1 ding ?
123 ding ?
123 ding ? 321
123 ding ? 457123 ding ? 457
1234567890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end