package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\D+`)
var str = `1 ding ?
123 ding ?
123 ding ? 321
123 ding ? 457123 ding ? 457
1234567890`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}