const regex = /\D+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\D+', 'gm')
const str = `1 ding ?
123 ding ?
123 ding ? 321
123 ding ? 457123 ding ? 457
1234567890`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}