// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\D+").unwrap();
let string = "1 ding ?
123 ding ?
123 ding ? 321
123 ding ? 457123 ding ? 457
1234567890";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}