#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\G(?!^);|Seats:\s*)\K\d+"
Local $sString = "Seats: 11;12;" & @CRLF & _
"Name: qqqq;wwww;" & @CRLF & _
"Start: Прешов, АВ Košická 2725/2" & @CRLF & _
"End: Мукачево, АЗ Лавковская, 1б" & @CRLF & _
"Date: 2019-06-22" & @CRLF & _
"Time: 09:40 PM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")